Archivos de Tags: script

Mikrotik: Enviando el log por mail

Un post interesante en el foro de Mikrotik un script que envía el log del RouterOS por mail, que si le hacemos un scheduler lo podemos programar para hacerlo cuando tengamos necesitas.

El script es sencillo y funciona sin problemas en la v3.

/system script add name=”LogDump” policy=ftp,reboot,read,write,policy,test,winbox,password,sniff

#read log
:local logcontent
:foreach int in=[/log find ] do={
:set logcontent (“$logcontentrn” .[/log get $int time]. ” – ” .[/log get $int message])
}
#send email
/tool e-mail send to=”log@xxxx.xxx” subject=([/system identity get name] . ” Log ” . [/system clock get date]) body=$logcontent
#delete old log
/system logging action set memory memory-lines=1
/system logging action set memory memory-lines=65000

RB411 Script de Alineaci�n

Encontré en el foro de Mikrotik una script que le será útil a muchos y sirve para hacer alineación con los leds del RB411, ha sido testeado con la v3.7 y permite ajustar los niveles de señal a nuestro gusto

:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=1 do={
  :if ($"signal-strength" <= -90) do={
   :led led1=no led2=no led3=no led4=no led5=no;
   }
  :if ($"signal-strength" <= -85 && $"signal-strength" > -90) do={
   :led led1=yes led2=no led3=no led4=no led5=no;
   } 
  :if ($"signal-strength" <= -80 && $"signal-strength" > -85) do={
   :led led1=yes led2=yes led3=no led4=no led5=no;
   } 
  :if ($"signal-strength" <= -75 && $"signal-strength" > -80) do={
   :led led1=yes led2=yes led3=yes led4=no led5=no;
   }
  :if ($"signal-strength" <= -65 && $"signal-strength" > -75) do={
   :led led1=yes led2=yes led3=yes led4=yes led5=no;
   } 
  :if ($"signal-strength" <= -20 && $"signal-strength" > -65) do={
   :led led1=yes led2=yes led3=yes led4=yes led5=yes;
   } 
}
}