Archivos de Tags: routeros

Mikrotik Virtualización

Una de las últimas novedades por parte de la gente de Mikrotik dejará a  más de uno con la boca abierta; en la versión v3.11 se le agregará al RouterOS la capacidad de correr sistemas operativos (guests) bajo el RouterOS como host.

Todo funcionará en los sistemas que permitan virtualización (i386) y que soporten XEN, a decir, Mikrotik RouterOS podrá correr distintos sistemas operativos que puedan ser virtualizados, con ello podremos correr un mailserver y un webserver bajo un Mikrotik como anfitrión de los Sistemas Operativos.

Se podrá crear interfaces dinámicas o fijas, también se podrán importar imágenes ya hechas de sistemas.

Se puede leer la documentación en el wiki de Mikrotik

Mikrotik: Enviando el log por mail

Un post interesante en el foro de Mikrotik un script que envía el log del RouterOS por mail, que si le hacemos un scheduler lo podemos programar para hacerlo cuando tengamos necesitas.

El script es sencillo y funciona sin problemas en la v3.

/system script add name=”LogDump” policy=ftp,reboot,read,write,policy,test,winbox,password,sniff

#read log
:local logcontent
:foreach int in=[/log find ] do={
:set logcontent (“$logcontentrn” .[/log get $int time]. ” – ” .[/log get $int message])
}
#send email
/tool e-mail send to=”log@xxxx.xxx” subject=([/system identity get name] . ” Log ” . [/system clock get date]) body=$logcontent
#delete old log
/system logging action set memory memory-lines=1
/system logging action set memory memory-lines=65000

Mikrotik v3.10 liberada

Recién me llega el mailing de Mikrotik informando que una nueva versión v3.10 del RouterOS ha sido liberada y lo interesante son la lista de agregados que tiene, son varios los interesantes entre ellos:

  • added fan control for RB433;
  • ipsec - added Dead Peer Detection
  • added address-list attribute support in user-manager

Acá le paso el changelog parcial, pueden ver el completo también. Pueden bajar el RouterOS de la página de Mikrotik.

What’s new in 3.10:
*) added Multilink PPP to PPPoE client – just specify multiple interfaces

to enable it;

*) added ability to add dynamicly PPTP, L2TP & PPPoE client addresses

to firewall address-list, specified in ppp profile,

or via RADIUS in Mikrotik:19;

*) added address-list attribute support in user-manager;

*) added fan control for RB433;

*) api – some properties were included multiple times in getall responses;

*) port – properly tag all inactive ports;

*) port – fixed memory leak that was triggered by addition/removal of

USB serial ports;

*) changed post-boot critical log messages – write a separate log entry

explainig the cause of an non-administrative reboot, such as watchdog

ping timeout, even if system rebooted cleanly;

*) fixed user-manager ‘database rebuild’ command to correct database errors;

*) fixed bug – user-manager customer password was not decoded

correctly when database backup was transferred

between Intel/RB100/RB500 and RB300/RB400/RB600/RB1000;

*) fixed bug – “/blink” command did not work on RB300/RB600/RB1000;

*) allow to configure OSPF authentication key ID;

*) allow to include bridge interface in a mesh interface;

*) ipsec – added Dead Peer Detection;

*) fixed some random crashes on RB411 & RB433;

*) fixed bug – OpenVPN could corrupt data on high load and force other end to disconnect;

*) fixed bug – DHCP server did not return DHCP options in response to

DHCPINFORM request;

Super Mario Bros en Mikrotik

Durante el MUM de Chicago en un recreo dieron a conocer este script que utiliza el comando beep y delay de mikrotik para crear el theme del super mario bros con el speaker del RouterBoard.

Muy buena idea y que paciencia para crearla. Según el wiki dice que fue creada "a oido" ya que no tiene las frecuencias correctas.

Super Mario Bros en Mikrotik 

Mikrotik: Liberada v3.9

Algo raro debe haber pasado en la versión v3.8 que solo pasaron algunas horas para que la v3.9 viera la luz, al parece ha habido un problema con el driver de la AR5212 y cuando el router trabaja en bridge, por lo menos eso dice el changelog oficial.

Hay algunos post en los foros que comenta que la versión del proxy desde la 3.4 en adelante no esta funcionando para cachear .exe, .iso, etc, solo esta cacheando las imagenes. Yo he estado haciendo algunas pruebas y no he tenido ese problema pero es bueno saberlo. 

Por cierto, han agregado muchos mirrors a las descarga. 

What's new in 3.9:
*) bridge could make router busy even without traffic;
*) fixed route redistribution in RIP (bug introduced in 3.8);
*) fixed AR5212 kernel crash on setting change;

Mikrotik Download Routeros 

Actualizaciones Mikrotik

Hoy día salieron 2 actualizaciones para los RouterOS, una es la que había quedado pendiente hace tiempo, la 2.9.51, con una de las actualizaciones era esperada, la corrección de un bug para la base de datos del User Manager cuando pasaba los 21MB.  Otro arreglo de esta versión es el traffic shaping del P2P Ares.

En la versión de la rama v3 tenemos otra actualización, una interesante esta a nivel del proxy que ahora cuando se define una src-address las conecciones salientes la utilizarán. También hay agregados a nivel de comandos monitor en consola y el arreglo para Vlan a nivel Wireless. Acá van los changelogs de uno y otro. Pueden bajar las versiones en el sitio de Mikrotik

What's new in 3.4:

*) improve transmit lockup detection to work around issues with few wireless
clients;
*) fixed bug – RB100/RB500 upgrade from RouterOS v2.9 could fail if
version 2.9 was installed by netinstall from v3;
*) console – compatibility syntax for 'find' and 'print where' expressions.
If = or != operation has as the left operand name of item property, without
leading '$', then right hand operand is parsed according to the syntax
of that propery. This also adds back command line completions. Example:
/ip address print where interface=ether1
ether1 was parsed as a reference to variable "ether1", now it is parsed as
name of the interface, like in version 2.9;
*) backup – proceed on read errors, log errors with topics "backup, critical";
*) console – allow commands like 'monitor' and '/tool fetch' in scheduler
scripts;
*) web proxy – when src-address is specified, use it for outgoing connections;
*) fixed crash in pppoe, pptp & l2tp when using ip pools with radius server;
*) added support for Option Fusion UMTS Quad-GPRS (Vodafone Globetrotter);
*) fixed VLAN on wireless not running after reboot issue;

What's new in 2.9.51:

*) graphing – fixed bug;
*) fixed bug – user manager database in-use counter was wrong
for database size over 21 MB;
*) fixed p2p – bandwidth shaping on ARES P2P traffic was not working properly;
*) fixed bug – dhcp server failed to give out options with code > 127;
*) fixed bug – r8169 could crash the router after some time;
*) graphing – bugfixes; health section restored;
*) user manager – fixed security bug in user page;
*) user manager – fixed ampersand bug;
*) user manager – fixed bug related to download/upload counter overflow in reports;