Archivos de Tags: MikroTik

Mikrotik Virtualización

Una de las últimas novedades por parte de la gente de Mikrotik dejará a  más de uno con la boca abierta; en la versión v3.11 se le agregará al RouterOS la capacidad de correr sistemas operativos (guests) bajo el RouterOS como host.

Todo funcionará en los sistemas que permitan virtualización (i386) y que soporten XEN, a decir, Mikrotik RouterOS podrá correr distintos sistemas operativos que puedan ser virtualizados, con ello podremos correr un mailserver y un webserver bajo un Mikrotik como anfitrión de los Sistemas Operativos.

Se podrá crear interfaces dinámicas o fijas, también se podrán importar imágenes ya hechas de sistemas.

Se puede leer la documentación en el wiki de Mikrotik

NanoStation se hace pasar por un Mikrotik

Este es un tema que hace tiempo le esta planteando Mikrotik a la gente de Ubiquiti para que lo solucionen. Es que los NanoStation, al momento de registrarse inalambricamente, se hacen pasar por un Mikrotik, dando una versión de RouterOS y un RadioName, atributos que son propios del RouterOS Mikrotik.

La versión que da el Nanostation es la 2.9.31 y el RadioName UBNT, estos datos, según Mikrotik, no estan haciendo mas que confundir a los usuarios de su sistema y le han enviado varias peticiones a la gente de Ubiquiti para que quiten este atributo, pero no han tenido respuesta.

A continuación una captura:

Mikrotik: Enviando el log por mail

Un post interesante en el foro de Mikrotik un script que envía el log del RouterOS por mail, que si le hacemos un scheduler lo podemos programar para hacerlo cuando tengamos necesitas.

El script es sencillo y funciona sin problemas en la v3.

/system script add name=”LogDump” policy=ftp,reboot,read,write,policy,test,winbox,password,sniff

#read log
:local logcontent
:foreach int in=[/log find ] do={
:set logcontent (“$logcontentrn” .[/log get $int time]. ” – ” .[/log get $int message])
}
#send email
/tool e-mail send to=”log@xxxx.xxx” subject=([/system identity get name] . ” Log ” . [/system clock get date]) body=$logcontent
#delete old log
/system logging action set memory memory-lines=1
/system logging action set memory memory-lines=65000

Mikrotik v3.10 liberada

Recién me llega el mailing de Mikrotik informando que una nueva versión v3.10 del RouterOS ha sido liberada y lo interesante son la lista de agregados que tiene, son varios los interesantes entre ellos:

  • added fan control for RB433;
  • ipsec - added Dead Peer Detection
  • added address-list attribute support in user-manager

Acá le paso el changelog parcial, pueden ver el completo también. Pueden bajar el RouterOS de la página de Mikrotik.

What’s new in 3.10:
*) added Multilink PPP to PPPoE client – just specify multiple interfaces

to enable it;

*) added ability to add dynamicly PPTP, L2TP & PPPoE client addresses

to firewall address-list, specified in ppp profile,

or via RADIUS in Mikrotik:19;

*) added address-list attribute support in user-manager;

*) added fan control for RB433;

*) api – some properties were included multiple times in getall responses;

*) port – properly tag all inactive ports;

*) port – fixed memory leak that was triggered by addition/removal of

USB serial ports;

*) changed post-boot critical log messages – write a separate log entry

explainig the cause of an non-administrative reboot, such as watchdog

ping timeout, even if system rebooted cleanly;

*) fixed user-manager ‘database rebuild’ command to correct database errors;

*) fixed bug – user-manager customer password was not decoded

correctly when database backup was transferred

between Intel/RB100/RB500 and RB300/RB400/RB600/RB1000;

*) fixed bug – “/blink” command did not work on RB300/RB600/RB1000;

*) allow to configure OSPF authentication key ID;

*) allow to include bridge interface in a mesh interface;

*) ipsec – added Dead Peer Detection;

*) fixed some random crashes on RB411 & RB433;

*) fixed bug – OpenVPN could corrupt data on high load and force other end to disconnect;

*) fixed bug – DHCP server did not return DHCP options in response to

DHCPINFORM request;

Mikrotik: Nuevos Packetes de Ruteo

Mikrotik ha liberado unos nuevos paquetes de routing-test y mpls-test. Estos le agregan nuevas funcionalidades a los paquetes de routing actuales de MPLS y BGP.

Los nuevos agregados a nivel MPLS son mencionados en artículos del wiki, aclara que esos  agregados son con el paquete nuevo.

La nueva documentación disponible en el wiki corresponden a: 

Virtual Routing and Forwarding

MPLS_TE_Tunnels

BGP Based VPLS 

Lástima que la documentación aún de estos temas es escasa, pero seguramente en los próximos meses ya tendremos disponible toda la documentación.

Para bajar los nuevos paquetes, vayan al sitio de download de Mikrotik .

Super Mario Bros en Mikrotik

Durante el MUM de Chicago en un recreo dieron a conocer este script que utiliza el comando beep y delay de mikrotik para crear el theme del super mario bros con el speaker del RouterBoard.

Muy buena idea y que paciencia para crearla. Según el wiki dice que fue creada "a oido" ya que no tiene las frecuencias correctas.

Super Mario Bros en Mikrotik 

Mikrotik: Liberada v3.9

Algo raro debe haber pasado en la versión v3.8 que solo pasaron algunas horas para que la v3.9 viera la luz, al parece ha habido un problema con el driver de la AR5212 y cuando el router trabaja en bridge, por lo menos eso dice el changelog oficial.

Hay algunos post en los foros que comenta que la versión del proxy desde la 3.4 en adelante no esta funcionando para cachear .exe, .iso, etc, solo esta cacheando las imagenes. Yo he estado haciendo algunas pruebas y no he tenido ese problema pero es bueno saberlo. 

Por cierto, han agregado muchos mirrors a las descarga. 

What's new in 3.9:
*) bridge could make router busy even without traffic;
*) fixed route redistribution in RIP (bug introduced in 3.8);
*) fixed AR5212 kernel crash on setting change;

Mikrotik Download Routeros 

Mikrotik News 9

Mikrotik ha sacado la revista bisemanal no. 9 con algunos anuncios interesantes:

Entre ellos los nuevos RouterBoard RB411A y RouterBoard RB433, el primero es una mejora del anterior 411 ya que tiene el doble de memoria (64MB) y trae una licencia Level4. El otro router será el que reemplazará al RB133 y el RB333, la perfomance el routerboard este es buena según las pruebas realizadas. También traer 64MB de ram.

Otro RB que hace su presentación es el RB450, este reemplazará al RB150 ya que es 5 veces mas rápido y encima cuesta lo mismo, además cabe en el mismo case y tiene los mismos esqueñas de montaje. Este dispositivo estará disponible en el mes de mayo. 

La revista también cuenta que el RB1000 ya esta liberado para su venta general, anteriormente costaba conseguir algún prototipo de estos, pero ahora ya esta masivamente en todos lados. 

Predator: Internet para largas distancias

El artículo original hace una excelente introducción:

Te encuentras sentado en una habitación de un hotel que no te ofrece internet inalámbrico. Miras por la ventana y observas 3 hoteles y un StarBucks mas adelante de la calle con una publicidad "Internet Inalambrico Free", si lo hubiera sabido cuando hice la reservación! Sacás la placa inalámbrica, pero la señal no lo suficientemente buena para mantener la conexión. Que es lo que vas a hacer?

Ingresar "The Predadot".

Esta  es la manera que le hace la presentación a este sistemita que vemos en la foto. Se trata de un router Buffalo, una antena Hyperlink de 14.5db yagi y un tripode entre otras cosas. La idea de utilizar este combo es poder tomar señal desde lugares distantes en los momentos en que por ejemplo si estamos en un hotel que no tiene internet o estamos en alguna zona donde hay un free internet hotspot podemos estar conectados.

Luego esta la configuración del router y la forma de ensamblaje del sistemita. Lo bueno de esto cuando lo vi, es que se puede hacer fácilmente con Mikrotik, ya que podemos poner un Routerboard 133 y hacer la configuración para que tome el sistema de hotspot y repartir la señal ya sa inalambricamente o por cable ethernet.

Es interesante la idea y que puede ayudar en algunos casos….

i-Hacked.com – The Predator

How To: QoS y Traffic Shaping en Linux

Uno de los temas que mas me gusta estudiar es lo referente  a la Calidad de Servicio, siempre hay maneras ingeniosas para obtener una mejor QoS en nuestra red. De eso también hable en la ponencia que hice en el MUM de Argentina.

Hace tiempo encontré, pero no había podido verlo con detenimiento, un articulo que habla de como darle Calidad de Servicio a la VoIP  (asterisk) a través de TOS para las comunicaciones de voz haciendo una coleta tc y reordenando el tráfico, así cuando se esta navegando se pueda hablar sin problemas ni delays.

El artículo es interesante ya que lo mismo se puede lograr hacer con Mikrotik y colocarlo en una red en el router de core puede ayudar notablemente con la calidad del servicio.

Página 1 de 212