RapidShare: Limitando ancho de banda

Una idea bastante ingeniosa para los que quieran limitar el ancho de banda de Rapidshare a un valor diferente del que se puede tener para el trafico web normal es haciendo lo siguiente:

Primero cargar el script que se encuentra al final de este post, lo que hace el script es toma los IP que se tengan en la tabla de dns con la cadena rapidshare, a eso lo agrega a una lista temporaria (address-list). Lo siguiente para hacer es hacer un mangle de esos ips con una marca y luego sencillamente hacer un queue para esa marca de flujo para limitarle el ancho de banda que se requiera

Esta idea la entontre en el foro de mikrotik de indonesia y que me pareció aparte de ingeniosa, útil para los que quieran limitar este tipo de sitio.

Acá va el script:

:foreach i in=[/ip dns cache find]  
 do={ :if ([:find [/ip dns cache get $i name] "rapidshare"] > 0)  
do={ :log info ("rapidshare: " . [/ip dns cache get $i name] . 
  " (ip address " . [/ip dns cache get $i address] . ")")  
/ip firewall address-list add address=[/ip dns cache get $i address] 
list=rapidshare disabled=no } }

via: forummikrotik 

2 comentarios

  1. Muy buena idea. La probare ahora mismo. Un saludo.

  2. Hi elmaxi,

    I see that you’ve found out about our forum and it’s nice to see that our work have been acknowledge by people from outside of our country.

    Looking forward to get to know you more and all of others that’s also using mikrotik. Hope to benefit each other by sharing our knowledge and helping each other.

    Cheers