Página 16 de 161

Instalando FreeBSD en RouterBOARDs

Siempre se ha intentado instalar otros sistemas operativos en los RouterBOARD, reemplazando así el RouterOS con la pérdida de la licencia que trae, ya que se formatea la NAND.

Buscando algunas referencias encontré un mini how-to que nos ayuda a parchear e instalar FreeBSD en un RouterBOARD (según pude ver con de las Series 400 -Arquitectura mips-).

Según comenta la información, que ya está desactualizada el manual, pero sirve de referencia, al igual que los parches que se deben aplicar para dejarlo funcional.

En la misma documentación se encuentra como instalar FreeBSD en RouterStation / RouterStation PRO que son los routers de Ubiquiti que no traen AirOS embebido.

Ver info

Excelente consola para terminal de Winbox

Un agregado para colocarle a la consola del terminal que nos brinde algo de información que nosotros querramos, se puede realizar de una manera simple.

La idea es bien simple y se puede realizar en cualquier versión del RouterOS. Es un script que toma los datos y los guarda en variables y luego al momento de salir a consola se le agrega un /system note

El resultado sería algo asi:

El codigo del script:

 
:local content
:local logcontenttemp ""
:local logcontent ""
:local counter
:local v 0

:set logcontenttemp "You are logged into: $[/system identity get name]"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")

:set logcontenttemp "############### system health ###############"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")

:set logcontenttemp "Uptime:  $[/system resource get uptime] d:h:m:s"
:set logcontent ("$logcontent" ."$logcontenttemp" ." | ")

:set logcontenttemp "CPU: $[/system resource get cpu-load]%"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")

:set logcontenttemp "RAM: $(([/system resource get total-memory]-[/system resource get free-memory])/1024)/$([/system resource get total-memory]/1024)M"
:set logcontent ("$logcontent" ."$logcontenttemp" ." | ")

##
#voltage and temp readout not available on x86, check for this before trying
#to record otherwise script will halt unexpectedly
##

:if ([/system resource get architecture-name]="x86") do={
:set logcontenttemp "Voltage: NIL"
:set logcontent ("$logcontent" ."$logcontenttemp" ." | ")
:set logcontenttemp "Temp: NIL"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")
} else={
:set logcontenttemp "Voltage: $[:pick [/system health get voltage] 0 2] v"
:set logcontent ("$logcontent" ."$logcontenttemp" ." | ")
:set logcontenttemp "Temp: $[ /system health get temperature]c"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")
}

:set logcontenttemp "############# user auth details #############"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")

:foreach counter in=[/ip hotspot active find ] do={:set v ($v + 1)}
:set logcontenttemp "Hotspot online: $v |"
:set v 0
:foreach counter in=[/ppp active find ] do={:set v ($v + 1)}
:set logcontenttemp ("$logcontenttemp" . " PPP online: $v")
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")

/system note set note="$logcontent"
 

vía: MikroTik-RouterOS

Entrenamientos en Junio: Honduras

Se brindarán los siguientes entrenamientos y certificaciones en San Pedro Sula, Honduras:

Ubiquiti UAC AirMAX: 10 y 11 de Junio

MTCNA: 3 al 6 de Junio

MTCTCE: 6 y 7 de Junio

Conociendo los hosts conectados en una red local

Hace un par de meses que me pase al mundo MAC, y debo admitir que la transición de Linux a MacOS ha sido mas simple de lo que esperaba, ya que la mayorías de las aplicaciones que uso son de código libre y las puedo utilizar en cualquier plataforma.

En relación a la administración de redes, el otro día tuve la necesidad de saber cuantos dispositivos conectados habían en un LAN, podría haber utilizado un escaneador de IP como Nmap, pero googleando encontré una solución mucho mas fácil y sin necesidad de instalar nada.

Si hacemos ping a la ip de broadcast y luego visualizamos los ARP podremos conocer los host disponibles en la LAN.

EJ: Teniendo el IP 192.168.10.4/24, el comando quedaría:

ping 192.168.10.255

Luego hacemos un:

arp -a

El resultado sería algo así:

internet.local.com (192.168.10.1) at 0:c:cc:cc:fa:7d on en0 ifscope [ethernet]
? (192.168.10.12) at 0:b:fa:aa:aa:dc on en0 ifscope [ethernet]
? (192.168.10.13) at 0:b:fa:aa:aa:dd on en0 ifscope [ethernet]

Excelente Tip. Vía: superuser

Kernel de Google Glass disponible

Hace un par de semana comente la posibilidad en Estados Unidos de probar o ser parte del proyecto Google Glass.

Hoy me encuentro que está disponible el Kernel (código fuente GPL) de Google Glass.

Excelente noticias para quienes les guste la fantasia 😉

Las Malvinas son Argentina…

Acabo de encontrar algo que me ha llamado la atención y hasta me ha agradado mucho. Haciendo unas conversiones de divisas en XE.com, me encontré que tienen a las Islas Malvinas como Argentina.

En la siguiente captura se puede apreciar que al intentar colocar Pesos Argentinos, me daba como opción a las Islas Malvinas.

Esto es bueno porque no la toman como Islas Falklands como las llaman los británicos y si por el nombre que les llamamos el resto del mundo, Islas Malvinas.

Internamente me da mucha bronca que en los tiempos que estamos viviendo y los maduras que están las sociedades, aún hayan este tipo de colonialismo, acto de pirateria y demás en un territorio. Discusión que será a lo mejor tratada en otro post.

Tan solo quería notar el llamado de Islas Malvinas como soberanía Argentina.

Especialización Wireless en Rosario, Argentina

Estaremos brindando una excelente jornada de especialización Wireless tanto de MikroTik RouterOS como Ubiquti en Rosario a mediados de Mayo.

MTCWE: 13 y 14 de Mayo – Ubiquiti AirMAX 15 y 16 de Mayo.

Mas información en www.AcademiaDeEntrenamientos.com

DNSCrypt: Seguridad en resoluciones DNS

Todos sabemos que el mundo de internet se mueve gracias al protocolo DNS, desde enviar un correo electrónico, navegar, etc etc.

El problema que tenemos, es que es un protocolo que facilmente puede ser «modificado» en el medio; la última milla es susceptible a envenenamiento de DNS, spoofing entre algunos tipos de ataques que puede tener este protocolo. De hecho hace tiempo hubo un «malware» que modificaba las resoluciones DNS que facilitaba el Phishing; al momento de ingresar al sitio del HomeBanking, éste malware nos redireccionaba a otro sitio pudiendo robarnos los datos de las cuentas bancarias.

OpenDNS, siempre a la vanguardia en DNS y seguridad, ha liberado una aplicación que permite encriptar nuestras peticiones DNS evitando así cualquier tipo de ataque.

Trabaja en el puerto 443 TCP, el mismo que se utiliza para HTTPS, así pasa desapercibido como una sesión SSL.

La lista de preguntas y respuesta sobre el servicio, al igual que la descarga de la aplicación se puede acceder desde el sitio oficial de DNSCrypt.

DNSCrypt

Entrenamiento Oficial Ubiquiti AirMAX, 13 y 14 de Mayo, Rosario, Argentina.

Se impartirá un Entrenamiento Oficial Ubiquiti AirMAX en Rosario, Argentina durante los días 13 y 14 de Mayo.

Mas información: UbiquitiCenter.com

Ubiquiti anuncia UniFi 3.0 con 802.11ac

Hace tiempo habíamos hablado del nuevo estandart 802.11ac que lo veiamos como un futuro medio lejano, pues ese momento ha llegado.

Ubiquiti ha anunciado que sus próximos UniFi 3.0 soportarán 802.11ac con lo que se podrá llegar a velocidades increíbles, de hasta 1.3Gbps dependiendo que modulación soporten.

Esta es una gran movida de Ubiquiti por dar primero el paso de implementación del estandart. Las soluciones tipo HotSpot sobre estas redes podrán disfrutar de grandes velocidades.

Se le ha preguntado a MikroTik que harán ellos y han respondido que están trabajando en soportar 802.11ac en un futuro cercano.

Se viene un gran cambio de nivel wireless, puedes conocer mas en detalle sobre el funcionamiento de 802.11ac en redeszone.net