CategorySeguridad

APK para limpiar los Ubiquiti infectados

Desde hace unos días se están infectando a nivel mundial los dispositivos de Ubiquiti que tienen un firmware desactualizado.

Esta infección la realiza un virus llamado «mother fucker» que explota una vulnerabilidad que fue solucionada el año pasado y que quienes no hayan actualizado, estan susceptible al ataque.

En un artículo que escribí en MKE Solutions hablo un poco mas del tema.

Hay varias opciones para hacer la limpieza pero una interesante es un APK para Android que permite realizar la limpieza de los dispositivos desde el mismo smartphone.

Aunque no es una APP oficial, los usuarios que la han probado dicen que funciona a la maravilla. Yo no uso Android por lo que no he podido usarla.

El APK se puede descargar directamente o se puede ingresar al proyecto app-ubnt-virus-cleaner en GitHub

MTHelper: Administrando dispositivos MikroTik

Hace unos días me llego una invitación para probar MTHelper, un servicio que permite administrar dispositivos MikroTik en la nube.

La idea es poder realizar cambios en la configuración de una manera bastante simple y con una interfaz amigable.

Se pueden realizar grupos y aplicarles un tipo de configuración en particular. También se pueden ver los registrados inalámbricos, sus niveles de señales, tráfico consumido entre algunos otros parámetros.

Dispone de un sistema de notificaciones al momento que se realiza alguna alerta o comportamiento, por ejemplo que el dispositivo se vuelta offline, cuando el CPU supere cierto valor, que notifique cuando llegue a cierta temperatura, etc.

Por ahora el sistema es gratuito y su registración esta abierta, veremos que sucede mas adelante.

Mas info: MTHelper

FutureISP: Primer Congreso Nacional de Proveedores de Brasil.

Hace tiempo me ha llegado la invitación para la primera edición del  FutureISP, un evento que se perfila como uno de los más importante de Brasil.

El primer Congreso Nacional de Proveedores (ISP) se realizará del 12 al 14 de Mayo en Olinda, Pernambuco, Brasil en el Centro de Convenciones de ese lugar.

Tiene una agenda interesante, con disertadores de diferentes índoles; unos 110 expositores y más de 9000 metros cuadrados de exposición.

Se puede leer más información del evento en el sitio oficial.

Blocklister: obteniendo listas de firewall para RouterOS

Un servicio que encontré leyendo algunos post en el foro de MikroTik es Blocklister, un servicio que genera listas de direcciones IP compatibles con RouterOS de las principales listas de internet como ser DShield o SpamHaus.

La lista completa de sitios al momento se puede encontrar en el proyecto GIT, donde también estan disponibles los pasos para hacer la instalación del sistema.

Estas listas se actualizan cada 2 días y permiten brindarle una protección adicional al routerOS.

Su funcionamiento es bastante simple, existe un listado de listas de acuerdo a lo que queramos bloquear, como por ejemplo, sitios con ads, spyware, proxy abiertos, spamhaus, etc. Una vez que definimos la lista, ésta es importada en un address list en el MikroTik y luego le hacemos el tratamiento que queramos.

Se puede leer mas del proyecto en GitHub

Bloqueando WhatsApp con MikroTik

Son muchos los entornos en donde se necesita bloquear las redes sociales, ya sea por seguridad o para evitar el ocio.

WhatsApp es una de las aplicaciones que se suele bloquear y hay varias maneras para hacerla.

La primera de ellas es hacer una entrada estática de DNS para c.whatsapp.com que es la que se utiliza para conectarse, dicha entrada puede tener 127.0.0.1 por ej.

La otra opción es por firewall evitando que se conecten a las redes que utiliza whatapps, para ello tenemos el listado de IP oficiales de este sistema de mensajería, tanto en IPv4 como IPv6.

Para acceder a dicho listado de redes hay que ingresar en https://www.whatsapp.com/cidr.txt

Adíos a Copy.com

El servicio que utilizaba para realizar mis backups personales llamado Copy.com, una división de Barracuda, del cual hable hace un tiempo, ha decidido cesar con sus servicios.

Según el comunicado oficial, van a dejar de brindar acceso a los archivos almacenados a partir del 1 de Mayo del 2016.

Han realizado un pequeño manual de como realizar la migración de los archivos hacia otro servicio Cloud de almacenamiento como DropBox, BoxGDrive, etc.

Según indican, fue una decisión muy dura pero la tomaron para poder dedicarse y enfocarse a otros proyectos.

Es una lastima, porque el servicio era muy bueno, rápido y sobre todo que te daba 25GB de almacenamiento con la cuenta free.

Ahora estoy migrando todos mis archivos a DropBox, pero lo que lamento es que voy a perder el backup que hacia en Copy.com de mis servidores de manera automatizada; para ello deberé buscar alguna nueva alternativa.

Mas info: Copy.com

hidden-tear: un ransomware open source

Hace unos días mi amigo Gabriel de SerInformatica me paso un enlace de un proyecto muy interesante, es un ransomware que tiene muchas funcionalidades.

No es que quiera hacer apología de esto, pero me pareció interesante el código y la manera que funciona esta herramienta. Como se sabe un ransomware es un aplicación que encripta los archivos de un sistema y luego para desencriptar esa información se requiere una llave.

Lo interesante de esto son las funcionalidades que se puede lograr tener. Creo que la mas interesantes es la de poder saltarse los principales antivirus y su pequeño tamaño.

Se puede ver mas información de la aplicación en el proyecto de GitHub y allí mismo ahondar en detalles interesantísimos que dispone.

La misma tiene un aviso legal que el mismo está destinado para propósitos de educación.

hidden-tear

Petición para liberar el Código Fuente del The DUDE

Una excelente iniciativa se la lanzado hace unos días desde Brasil, la petición de pedirle a MikroTik que libere el código fuente de la aplicación DUDE.

DUDE es una herramienta de monitoreo de dispositivos vía SNMP / RouterOS que tiene muchas ventajas (entre algunas es gratuito), pero su desarrollo ha quedado estancado desde hace mas de 5 años.

Desde hace tiempo los usuarios de MikroTik le piden que continúen el avance de la herramienta, pero según han comentado, su desarrollo se realiza en pasatiempos y desde que se lanzó la v6 no han podido continuar su programación, ya que están enfocados en el RouterOS.

Seguramente en parte del código fuente de la aplicación estarán datos de sus protocolos propietarios que dificultarán la publicación del mismo.

La petición es vía change.org, no se si le darán relevancia, pero me sumo para que tengan noción de los usuarios de la misma y la necesidad de continuar el proyecto. Al momento de escribir este post hay unas 125 firmas de 200 que se requieren.

Petición de Liberar el código de DUDE

Algunos datos interesantes

Desde hace tiempo tengo en favoritos algunos enlaces que mencionan datos interesantes que a continuación los compartiré.

Oficialmente MikroTik ha comprobado el perfomance de los CCRs trabajando con túneles IPSEC y surgieron los siguientes resultados:

CCR1036:
El máximo throughput alcanzado fue de 3.2Gbps con 34 túneles (full duplex)
1.8Gbps con 16 túneles
820Mbps con un GRE over IPSec (full duplex)

CCR1009:
1.6Gbps con 8 túneles full duplex
520Mbps con un GRE over IPSec (full duplex)

Los testeos fueron realizados con el traffic-generator y tamaños de paquetes de 1470 byte.

Bloqueando ataques SIP con Firewall MikroTik

Hace tiempo tuve la necesidad de proteger algunas centrales IP y desarrolle una serie de reglas que protegen a una central telefónica IP como un asterisk, de ataques SIP. Me la tuve que rebuscar bastante para lograr tener algo funcional.

Un usuario del foro de MikroTik ha desarrollado un par de regla simples t bastante interesantes  que permiten proteger una centralita.

La idea es mirar la primer registración sip (new) al puerto 5060 y si en 15 segundos no puede lograr el handshake (login) con el servidor -usualmente el registro llega 3 segundos como mucho-, lo coloca en una lista negra por 1 día para banear el IP.

Las reglas son:
/ip firewall filter add chain=forward in-interface=ether1-gateway src-address-list="SIP Hacker" action=drop
/ip firewall filter add chain=forward protocol=udp dst-port=5060 connection-state=new src-address-list="SIP Trial" in-interface=ether1-gateway action=add-src-to-address-list address-list="SIP Hacker" address-list-timeout=1d
/ip firewall filter add chain=forward src-address=0.0.0.0/0 protocol=udp dst-port=5060 in-interface=ether1-gateway connection-state=new action=add-src-to-address-list address-list="SIP Trial" address-list-timeout=00:00:15

Es una buena alternativa para hacer una protección básica de una centralita IP. Obvio que hay que se puede mejorar mucho mas, pero la base esta muy bien.

vía: MikroTik