Categoríamikrotikexpert

Reseña MUM Quito, Ecuador 2013

Anoche regrese de Ecuador, en donde estuvimos presente (MKE Solutions) en el MUM de Ecuador realizado la semana pasada.

La verdad que fue un excelente evento para ser el primero, por comentarios de la gente de MikroTik que anunciaban sorprenderse por la participación de casi 450 participantes al acontecimiento.

Nuestro Entrenamiento también tuvo una muy buena aceptación, cosa que hizo que llenará por completo los cupos entre participantes de diferentes países, los cuales compartimos muchos momentos y hemos entablado contacto.

Como siempre, me encontré con viejos amigos y también pude conocer a nuevos amigos que me hicieron pasar un momento muy grato.

Particularmente me sentí muy tranquilo en mi presentación y según me comentaron varios participantes del evento, le será de utilidad lo que compartí, ya que se ahorrarán bastante trabajo y tiempo en implementaciones en entornos de restauraciones (como un caso que me dijeron de reinstalación de imágenes de maquinas para Cibers).

También estuve por Ambato -ciudad cercana a Quito- para finalizar algunos trabajos de migración de una Red MPLS a Cloud Core con interconexión entre ellos vía fibra óptica por sus puertos SFP, con excelentes resultados en sus desempeños.

En Ambato tengo muchos amigos que siempre que voy me hacen pasar momentos únicos y reírme mucho -incluyendo una cena entre ellos en donde comimos una excelente lasaña-. Organizamos también dos partidos de fútbol en Cevallos, un pueblo cercano a Ambato, a unos 4000 mts. de altura. Fue muy complicado el tener un ritmo en el partido porque a esa altura te falta el aire y se siente mucho; las bocanadas de aire que uno da no alcanzan para recuperarse de los trotes y piques.

En el último partido que realizamos pudimos jugar con ex-jugadores de fútbol profesional de Ecuador -Famosos jugadores de primera-, que le agregaron un toque adicional al partido y al momento.

Otra cosa algo que he notado a Ecuador es el avance en las carreteras, desde el 2007 que voy a ese país y el crecimiento de las autopistas han mejorado mucho los viajes y los tiempos de desplazamiento entre las ciudades.

Eso es algo para felicitar porque es un avance para el pueblo ecuatoriano!

Retomando el tema del MUM, en los próximos días estaré realizando una reseña oficial en MKE Solutions y subiré las fotos y enlaces de las presentaciones.

MUM Ecuador. Noviembre 2013

En fin…en Ecuador me siento como en casa….Chulla vida Ecuador!

MKE Solutions, galardonada con el Premio a la Excelencia 2013

Que alegría y que orgullo; la semana pasada se hizo la entrega de los Premios a la Excelencia 2013 y MKE Solutions, fue ganadora del Primer Premio a la Excelencia 2013 otorgado por el IADE (Instituto Argentino de la Excelencia).

Este es el reconocimiento al trabajo, esfuerzo y dedicación a las tareas que realizamos. Al empeño que se pone en nuestro trabajo y el tener como objetivo ser los mejores en lo que hacemos.

La nota explicada en MKE Solutions

T50: Herramienta de testing y simulador de DDoS

T50 es una de esas herramientas que son útiles para poder emular diferentes tipos de ataques.

T50 es un inyector de paquetes multiprotocolo, de origen brasileño y que permite realizar ataques de DoS y DDoS utilizando el concepto de testeo por stress.

Soporta alguno de los siguientes protocolos o modos:

  • Flooding
  • CIRD support
  • TCP, UDP, ICMP, IGMPv2, ESP, AH, OSPF entre algunos
  • High Performance
  • Puede tener un HIT de 1 millón de paquetes por segundo

En los entrenamientos que impartimos, en los laboratorios de Firewall, utilizamos herramientas similares que realizan diferentes ataques y se aprende como protegerse a dichos ataques. Esta herramienta tiene bastantes tipos de protocolos que la posicionan muy bien con respecto a sus similares.

Es de código abierto con la licencia GNU GPLv2, se puede descargar y utilizar desde el proyecto de SF.net

MUM México 2013

Ya estoy de regreso por mi ciudad luego de pasar unos días por México participando de lo que fue el primer MikroTik User Meeting celebrado en ese país.

La verdad que esos eventos me encantan, porque me encuentro con muchos amigos y también conozco muchas personas que suelo tener contacto con ellos pero solo virtual y esos eventos son interesantes para conocerlas en persona.

También me gusta mucho porque puedo compartir momentos con la gente de MikroTik, aprovechamos cuando nos encontramos en algún para salir y hacer Geocaching, juego similar a una búsqueda del tesoro a nivel mundial y que compartimos en practicarlo.

El evento en si estuvo muy bien, unas 200 personas se acercaron de diferentes partes del mundo para participar; al principio pensé que iba a ver mas convocatoria pero analizando con MikroTik que es un número muy aceptable para un primer evento y que ahora queda en la comunidad el poder avanzar para que se pueda celebrar un nuevo evento en ese país.

Las presentaciones estuvieron interesantes, las mismas estarán en los próximos días disponibles para la descarga en el wiki de MikroTik.

Pronto subiré las fotos y también escribiré una reseña del evento en MKE Solutions.

Bloquear torrent de manera simple con RouterOS

Hay varias maneras de filtrar el torrent en RouterOS, pero una de las que publicaron en el foro de MikroTik ha dado un buen resultado.

Son 3 reglas que se colocan y lo que hacen es bloquear a través del content ciertos patrones que utilizan los programas de torrent para dropearlo.

Según comenta el usuario que lo comparte, se ha podido bloquear el torrent y comprobado con las siguientes aplicaciones:

  • uTorrent 3.30
  • Azureus 2.5.0.0
  • BitTorrent/4.1.2
  • BitComet/1.36.5.2
  • mediaget/2.01.2359

Las reglas y la descripción de como encontró los patrones están en el siguiente enlace.

Instalando Fedora usando MikroTik

Muchas veces suele suceder que necesitamos instalar un Sistema Operativo en un servidor que no tiene Lectora de CD.

Suponiendo que no tenga USB podemos utilizar PXE para enviarle una imagen ISO via red y hacer que el mismo botee e inicie con el mismo. Esto lo podemos hacer facilmente con MikroTik RouterOS ya que soporta TFTP & DHCP-SERVER.

Un paso a paso de como realizar está disponible para hacerlo con el Fedora 19. Son pocos los pasos y se puede utilizar con cualquier equipo que botee por red.

Interesante opción cuando necesitamos instalar un SO por red.

Major.io

Cambio de dominio en MKE Solutions

Como algunos ya sabrán estamos haciendo la migración del dominio de MKE Solutions a www.mkesolutions.net. Este cambio afectará tanto al sitio web como al correo electrónico que utilizamos, pero seguirán funcionando ambos dominios al mismo tiempo para que no haya pérdida de los correos con quienes utilicen el dominio anterior.

Al servidor web lo migramos a un nuevo VPS que está preparado para trabajar bajo carga en la plataforma WordPress, junto con un buen cache y el servicio de Cloud se puede tener excelentes tiempos de cargar y respuestas.

Lo mas complejo de la migración es la parte del servidor de correo, como nosotros enviamos boletines es necesario dar de alta el dominio en conjunto con las direcciones IP en los principales servidores de correo como Hotmail o Yahoo, suscribiendonos al sistema de Envio Masivo que tienen cada uno de ellos, para evitar que los correo que enviemos lleguen a Spam, pero es algo que lleva su buen tiempo, ya que hay ciertas validaciones que se realizan.

Luego de unos días que se compruebe que la migración se ha completado, me pondré a escribir varios post que tengo pendiente en el blog para que vuelta a tener algo de vida, porque está medio descuidado.

 

Instalando FreeBSD en RouterBOARDs

Siempre se ha intentado instalar otros sistemas operativos en los RouterBOARD, reemplazando así el RouterOS con la pérdida de la licencia que trae, ya que se formatea la NAND.

Buscando algunas referencias encontré un mini how-to que nos ayuda a parchear e instalar FreeBSD en un RouterBOARD (según pude ver con de las Series 400 -Arquitectura mips-).

Según comenta la información, que ya está desactualizada el manual, pero sirve de referencia, al igual que los parches que se deben aplicar para dejarlo funcional.

En la misma documentación se encuentra como instalar FreeBSD en RouterStation / RouterStation PRO que son los routers de Ubiquiti que no traen AirOS embebido.

Ver info

Excelente consola para terminal de Winbox

Un agregado para colocarle a la consola del terminal que nos brinde algo de información que nosotros querramos, se puede realizar de una manera simple.

La idea es bien simple y se puede realizar en cualquier versión del RouterOS. Es un script que toma los datos y los guarda en variables y luego al momento de salir a consola se le agrega un /system note

El resultado sería algo asi:

El codigo del script:

 
:local content
:local logcontenttemp ""
:local logcontent ""
:local counter
:local v 0

:set logcontenttemp "You are logged into: $[/system identity get name]"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")

:set logcontenttemp "############### system health ###############"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")

:set logcontenttemp "Uptime:  $[/system resource get uptime] d:h:m:s"
:set logcontent ("$logcontent" ."$logcontenttemp" ." | ")

:set logcontenttemp "CPU: $[/system resource get cpu-load]%"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")

:set logcontenttemp "RAM: $(([/system resource get total-memory]-[/system resource get free-memory])/1024)/$([/system resource get total-memory]/1024)M"
:set logcontent ("$logcontent" ."$logcontenttemp" ." | ")

##
#voltage and temp readout not available on x86, check for this before trying
#to record otherwise script will halt unexpectedly
##

:if ([/system resource get architecture-name]="x86") do={
:set logcontenttemp "Voltage: NIL"
:set logcontent ("$logcontent" ."$logcontenttemp" ." | ")
:set logcontenttemp "Temp: NIL"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")
} else={
:set logcontenttemp "Voltage: $[:pick [/system health get voltage] 0 2] v"
:set logcontent ("$logcontent" ."$logcontenttemp" ." | ")
:set logcontenttemp "Temp: $[ /system health get temperature]c"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")
}

:set logcontenttemp "############# user auth details #############"
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")

:foreach counter in=[/ip hotspot active find ] do={:set v ($v + 1)}
:set logcontenttemp "Hotspot online: $v |"
:set v 0
:foreach counter in=[/ppp active find ] do={:set v ($v + 1)}
:set logcontenttemp ("$logcontenttemp" . " PPP online: $v")
:set logcontent ("$logcontent" ."$logcontenttemp" ."\n")

/system note set note="$logcontent"
 

vía: MikroTik-RouterOS

Especialización Wireless en Rosario, Argentina

Estaremos brindando una excelente jornada de especialización Wireless tanto de MikroTik RouterOS como Ubiquti en Rosario a mediados de Mayo.

MTCWE: 13 y 14 de Mayo – Ubiquiti AirMAX 15 y 16 de Mayo.

Mas información en www.AcademiaDeEntrenamientos.com